Qt4项目迁移到Qt5问题:greaterThan(QT_MAJOR_VERSION, 4): QT += widgets

来源:互联网 发布:海岛奇兵菊花升级数据 编辑:程序博客网 时间:2022/07/04 22:23

文章来源:http://blog.csdn.net/ccf19881030/article/details/18220447

问题一:错误:C1083: 无法打开包括文件:“QApplication”: No such file or directory

出现原因:Qt5里不再用QtGui模块,而是使用QtWidgets模块。

解决方法:在*.pro里加上greaterThan(QT_MAJOR_VERSION, 4): QT += widgets


问题二:Qt 5.2 使用原来的QT4.8.4项目时QWebView 、QWebFrame等类无法编译通过。

出现原因:QWebView 、QWebFrame、QWebPage、QWebInspector等这些类被单独移到了QtWebKitWidgets模块,不再在QtWebKit模块当中;而QWebHistory等类仍然保留在QtWebkit模块中。

解决方法:使用到QWebPage等webkit相关可视部件的,Qt5.2单独放到了QtWebKitWidgets模块中,所以在使用了QWebPage类的地方:

(1)在*.pro中要加QT += webkitwidgets

(2)在*.cpp中加头文件:#include <QtWebKitWidgets/QWebPage>

或者#include<QWebPage>

QT5.2对QT4.x的改动比较大,关于QT5.2可以从QT官网:Qt 5.2 is Here!找到相关介绍。

参考资料:

1、将某个Qt4项目升级到Qt5遇到的问题

2、Qt 使用QWebView 编译无法通过

3、qt windows 5.0.2没法使用qwebview。

0 0