OSPF DR using Router-ID

来源:互联网 发布:最优化方法第二版施 编辑:程序博客网 时间:2024/05/08 20:37
 
hostname r1

interface Loopback0
ip address 10.1.1.1 255.255.255.0

interface Serial0/0
ip address 123.1.1.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 123.1.1.3 102
frame-relay map ip 123.1.1.2 102 broadcast
no frame-relay inverse-arp

router ospf 1
network 10.1.1.0 0.0.0.255 area 10
network 123.1.1.0 0.0.0.255 area 10
----------------------------------------------
hostname r2

interface Loopback0
ip address 20.1.1.1 255.255.255.0

interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 multipoint
ip address 123.1.1.2 255.255.255.0
frame-relay interface-dlci 201
frame-relay interface-dlci 203

router ospf 1
router-id 255.255.255.255
network 20.1.1.0 0.0.0.255 area 10
network 123.1.1.0 0.0.0.255 area 10
----------------------------------------------
hostname r2

interface Loopback0
ip address 20.1.1.1 255.255.255.0

interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.1 multipoint
ip address 123.1.1.2 255.255.255.0
frame-relay interface-dlci 201
frame-relay interface-dlci 203

router ospf 1
router-id 255.255.255.255
network 20.1.1.0 0.0.0.255 area 10
network 123.1.1.0 0.0.0.255 area 10
----------------------------------------------
hostname r3

interface Loopback0
ip address 30.1.1.1 255.255.255.0
!
interface Serial0/0
ip address 123.1.1.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 123.1.1.1 302
frame-relay map ip 123.1.1.2 302 broadcast
no frame-relay inverse-arp

router ospf 1
network 30.1.1.0 0.0.0.255 area 10
network 123.1.1.0 0.0.0.255 area 10
----------------------------------------------
r1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/32 is subnetted, 1 subnets
O 20.1.1.1 [110/65] via 123.1.1.2, 00:10:57, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Loopback0
123.0.0.0/24 is subnetted, 1 subnets
C 123.1.1.0 is directly connected, Serial0/0
30.0.0.0/32 is subnetted, 1 subnets
O 30.1.1.1 [110/65] via 123.1.1.3, 00:10:57, Serial0/0

r1#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
255.255.255.255 1 FULL/DR 00:01:35 123.1.1.2 Serial0/0
r1#sh ip os int s0/0
Serial0/0 is up, line protocol is up
Internet Address 123.1.1.1/24, Area 10
Process ID 1, Router ID 123.1.1.1, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 255.255.255.255, Interface address 123.1.1.2
Backup Designated router (ID) 123.1.1.1, Interface address 123.1.1.1
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:04
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 255.255.255.255 (Designated Router)
Suppress hello for 0 neighbor(s)
---------------------------------------------------------------
r2#sh ip os nei

Neighbor ID Pri State Dead Time Address Interface
123.1.1.1 1 FULL/DROTHER 00:01:51 123.1.1.1 Serial0/0.1
123.1.1.3 1 FULL/BDR 00:01:47 123.1.1.3 Serial0/0.1

r2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/24 is subnetted, 1 subnets
C 20.1.1.0 is directly connected, Loopback0
10.0.0.0/32 is subnetted, 1 subnets
O 10.1.1.1 [110/65] via 123.1.1.1, 00:13:29, Serial0/0.1
123.0.0.0/24 is subnetted, 1 subnets
C 123.1.1.0 is directly connected, Serial0/0.1
30.0.0.0/32 is subnetted, 1 subnets
O 30.1.1.1 [110/65] via 123.1.1.3, 00:13:29, Serial0/0.1

r2#sh ip os int s0/0.1
Serial0/0.1 is up, line protocol is up
Internet Address 123.1.1.2/24, Area 10
Process ID 1, Router ID 255.255.255.255, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 255.255.255.255, Interface address 123.1.1.2
Backup Designated router (ID) 123.1.1.3, Interface address 123.1.1.3
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 2
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 123.1.1.1
Adjacent with neighbor 123.1.1.3 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
-----------------------------------------------------------
r3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/32 is subnetted, 1 subnets
O 20.1.1.1 [110/65] via 123.1.1.2, 00:17:00, Serial0/0
10.0.0.0/32 is subnetted, 1 subnets
O 10.1.1.1 [110/65] via 123.1.1.1, 00:17:00, Serial0/0
123.0.0.0/24 is subnetted, 1 subnets
C 123.1.1.0 is directly connected, Serial0/0
30.0.0.0/24 is subnetted, 1 subnets
C 30.1.1.0 is directly connected, Loopback0
r3#sh ip os nei

Neighbor ID Pri State Dead Time Address Interface
255.255.255.255 1 FULL/DR 00:01:41 123.1.1.2 Serial0/0

r3#sh ip os int s0/0
Serial0/0 is up, line protocol is up
Internet Address 123.1.1.3/24, Area 10
Process ID 1, Router ID 123.1.1.3, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 255.255.255.255, Interface address 123.1.1.2
Backup Designated router (ID) 123.1.1.3, Interface address 123.1.1.3
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:10
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 255.255.255.255 (Designated Router)
Suppress hello for 0 neighbor(s)

文章转载至http://bbs.net527.cn  无忧网客联盟

无忧网客联盟主站

无忧linux时代

原创粉丝点击