在Ubuntu中安装Qt SDK时候遇到需要安装C++编译器的问题

来源:互联网 发布:网络诈骗的典型案例 编辑:程序博客网 时间:2021/02/27 01:52

在Ubuntu中安装Qt SDK时候遇到需要安装C++编译器的问题如下:

You need a C++ compiler. Please install it using the System Package Management tools.

Ubuntu缺省情况下,并没有提供C/C++的编译环境,因此还需要手动安装。这里介绍一种比较简单的方式利用编译Ubuntu的内核的工具build-essential软件包。
查看该软件包的依赖关系如下
$ apt-cache depends build-essential
build-essential
|依赖: libc6-dev
依赖: <libc-dev>
libc6-dev
依赖: gcc
依赖: g++
依赖: make
依赖: dpkg-dev
也就是说,安装了该软件包,编译c/c++所需要的软件包也都会被安装。
安装方法如下:

$sudo apt-get install build-essential